PMX Payments Delayed
Incident Report for Vanco
Resolved
Payments are being released, this is resolved.
Posted Mar 10, 2021 - 13:05 CST
Monitoring
The issue has been identified and corrected, payments in the process of being released.
Posted Mar 10, 2021 - 12:26 CST
Update
We are continuing to investigate this issue.
Posted Mar 10, 2021 - 12:04 CST
Update
We are continuing to investigate this issue.
Posted Mar 10, 2021 - 11:23 CST
Investigating
PMX Payment availability is currently delayed as payments have not been released yet. We are currently investigating a solution and an ETA for releasing payments.
Posted Mar 10, 2021 - 10:21 CST
This incident affected: Payment Exchange (Pre-processing Availability).